summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-04-18 23:20:50 +0000
committersamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-04-18 23:20:50 +0000
commit20b40b2428b6c6f555969d1efa909036ede5d8ef (patch)
treeb76d82146c2dd8876df7d5962c89f4fe1940d4c1 /CMakeLists.txt
parent1d9d9f5ce46f0220f7b1b350f5ad4e6dc5079ac6 (diff)
downloadamarok-20b40b2428b6c6f555969d1efa909036ede5d8ef.tar.gz
amarok-20b40b2428b6c6f555969d1efa909036ede5d8ef.zip
[applications/amarok] cmake generate docs
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/amarok@1228473 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 44cfd0ef..7ff5907d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,6 +48,12 @@ option( WITH_XINE "Enable xine-engine support" OFF )
option( WITH_LIBGPOD "Enable iPod support from libgpod" OFF )
+##### user requested modules ####################
+
+option( BUILD_ALL "Build all" OFF )
+option( BUILD_DOC "Build doc" ${BUILD_ALL} )
+
+
##### configure checks ##########################
include( ConfigureChecks.cmake )
@@ -68,6 +74,7 @@ set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
##### source directories ########################
add_subdirectory( amarok )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
##### write configure files #####################