summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-01-07 18:40:09 +0000
committersamelian <samelian@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-01-07 18:40:09 +0000
commit4eb340f04c965b67c95fc37c60beaa2f7959e342 (patch)
treecdaca2ca47db754de7952d73063d4947b2debd80 /CMakeLists.txt
parent6637c742279c9df570b3bd1d09244f1b0f66ee62 (diff)
downloadarts-4eb340f04c965b67c95fc37c60beaa2f7959e342.tar.gz
arts-4eb340f04c965b67c95fc37c60beaa2f7959e342.zip
[dependencies/arts] using our own macros to find Qt and TQt
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/dependencies/arts@1212629 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 3 insertions, 13 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 22ce656..d794ecf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -167,20 +167,10 @@ else( GLIB2_FOUND )
endif( GLIB2_FOUND )
-##### check for Qt3 #############################
+##### check for Qt3 and TQt #####################
-find_package( Qt3 )
-if( NOT QT_FOUND )
- message(FATAL_ERROR "\nQt3 are required, but not found on your system" )
-endif( NOT QT_FOUND )
-
-
-##### check for TQt #############################
-
-pkg_search_module( TQT TQt )
-if( NOT TQT_FOUND )
- message(FATAL_ERROR "\nTQt are required, but not found on your system" )
-endif( NOT TQT_FOUND )
+find_package( Qt )
+find_package( TQt )
##### write config.h file #######################