summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2022-08-10 21:15:01 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2022-08-10 21:15:01 +0900
commitfbe27fc928b3dc2dd9efb29b023399d1f0c3ebe1 (patch)
treeeebe0e90a8792d109b78cce21f041f6ed1d97d5b /CMakeLists.txt
parent0a2f5a792977b640e4d41f96f0523f416fac7359 (diff)
downloadarts-fbe27fc928b3dc2dd9efb29b023399d1f0c3ebe1.tar.gz
arts-fbe27fc928b3dc2dd9efb29b023399d1f0c3ebe1.zip
Use 'tde_setup_paths' macro to setup required paths.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 4 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7afbb66..96d138f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -43,13 +43,10 @@ include( TDEMacros )
tde_set_project_version( )
-##### paths setup ###############################
+##### setup install paths #######################
-tde_setup_install_path( EXEC_INSTALL_PREFIX "${CMAKE_INSTALL_PREFIX}" )
-tde_setup_install_path( BIN_INSTALL_DIR "${EXEC_INSTALL_PREFIX}/bin" )
-tde_setup_install_path( LIB_INSTALL_DIR "${EXEC_INSTALL_PREFIX}/lib${LIB_SUFFIX}" )
-tde_setup_install_path( INCLUDE_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/include/${CMAKE_PROJECT_NAME}" )
-tde_setup_install_path( PKGCONFIG_INSTALL_DIR "${LIB_INSTALL_DIR}/pkgconfig" )
+include( TDESetupPaths )
+tde_setup_paths( )
##### user requested options ####################
@@ -108,7 +105,7 @@ else( )
endif( )
string( REGEX REPLACE "^${CMAKE_INSTALL_PREFIX}" "\${prefix}" PC_EXEC_PREFIX ${EXEC_INSTALL_PREFIX} )
-string( REGEX REPLACE "^${CMAKE_INSTALL_PREFIX}" "\${prefix}" PC_INCLUDE_DIR ${INCLUDE_INSTALL_DIR} )
+string( REGEX REPLACE "^${CMAKE_INSTALL_PREFIX}" "\${prefix}" PC_INCLUDE_DIR ${INCLUDE_INSTALL_DIR}/${CMAKE_PROJECT_NAME} )
string( REGEX REPLACE "^${CMAKE_INSTALL_PREFIX}" "\${prefix}" PC_LIB_DIR ${LIB_INSTALL_DIR} )
configure_file( arts.pc.cmake arts.pc @ONLY )
install( FILES ${CMAKE_CURRENT_BINARY_DIR}/arts.pc DESTINATION ${PKGCONFIG_INSTALL_DIR} )