summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 3 insertions, 13 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 22ce656..d794ecf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -167,20 +167,10 @@ else( GLIB2_FOUND )
endif( GLIB2_FOUND )
-##### check for Qt3 #############################
+##### check for Qt3 and TQt #####################
-find_package( Qt3 )
-if( NOT QT_FOUND )
- message(FATAL_ERROR "\nQt3 are required, but not found on your system" )
-endif( NOT QT_FOUND )
-
-
-##### check for TQt #############################
-
-pkg_search_module( TQT TQt )
-if( NOT TQT_FOUND )
- message(FATAL_ERROR "\nTQt are required, but not found on your system" )
-endif( NOT TQT_FOUND )
+find_package( Qt )
+find_package( TQt )
##### write config.h file #######################