summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 10 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 024e833..b014074 100644
--- a/configure.ac
+++ b/configure.ac
@@ -480,10 +480,16 @@ AC_ARG_ENABLE(tqt,
[HAVE_TQT=yes])
if test "x$HAVE_TQT" = "xyes" ; then
- PKG_CHECK_MODULES( QT3, [ qt-mt >= 3.0.0 ])
- AC_SUBST(QT3_CFLAGS)
- AC_SUBST(QT3_LIBS)
- QT3_PREFIX="`$PKG_CONFIG --variable=prefix qt-mt`/bin"
+ PKG_CHECK_MODULES( QT3, [ qt-mt >= 3.0.0 ],
+ [AC_SUBST(QT3_CFLAGS)
+ AC_SUBST(QT3_LIBS)
+ QT3_PREFIX="`$PKG_CONFIG --variable=prefix qt-mt`/bin"
+ ],
+ [PKG_CHECK_MODULES( QT3, [ tqt-mt ] )
+ AC_SUBST(QT3_CFLAGS)
+ AC_SUBST(QT3_LIBS)
+ QT3_PREFIX="`$PKG_CONFIG --variable=prefix tqt-mt`/bin"
+ ])
AC_PATH_PROGS(MOC_QT3, [moc-tqt moc], no, [$QT3_PREFIX])
if test "$MOC_QT3" = no; then
AC_MSG_ERROR([Could not find QT3 moc])