summaryrefslogtreecommitdiffstats
path: root/src/app/CMakeLists.txt
diff options
context:
space:
mode:
authormio <stigma@disroot.org>2024-11-10 19:39:43 +1000
committermio <stigma@disroot.org>2025-01-06 20:11:48 +1000
commit05c7ba1a96b7b10e4debec2764582bda8503f547 (patch)
tree2c1261d69610d972c08803ad6a5578c93b9a2a28 /src/app/CMakeLists.txt
parente023e2eafb5dc39fe11595f343d867ac6ebe7f5b (diff)
downloadcodeine-05c7ba1a96b7b10e4debec2764582bda8503f547.tar.gz
codeine-05c7ba1a96b7b10e4debec2764582bda8503f547.zip
Create a AudioView widget for audio-only streamsissue/23/add-audio-view
Currently Codeine will show a blank area when playing an audio-only file, such as music. This patch adds a new widget that contains an instance of the Analyzer::Block class, so instead of a blank area it contains a "visualizer" of sorts. Signed-off-by: mio <stigma@disroot.org>
Diffstat (limited to 'src/app/CMakeLists.txt')
-rw-r--r--src/app/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/app/CMakeLists.txt b/src/app/CMakeLists.txt
index 60a21e4..eb10736 100644
--- a/src/app/CMakeLists.txt
+++ b/src/app/CMakeLists.txt
@@ -35,6 +35,7 @@ tde_add_executable( ${PROJECT_NAME} AUTOMOC
playDialog.cpp
listView.cpp
adjustSizeButton.cpp
+ audioView.cpp
fullScreenAction.cpp
insertAspectRatioMenuItems.cpp
playlistFile.cpp