summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 90a841b..66f5cb6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,9 +18,20 @@ cmake_minimum_required( VERSION 2.8 )
include( FindPkgConfig )
include( CheckCXXSourceCompiles )
+include( CheckSymbolExists )
set( CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules" )
include( TDEMacros )
+
+
+##### optional stuff
+
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+
+
+##### configure checks ##########################
+
include( ConfigureChecks.cmake )