summaryrefslogtreecommitdiffstats
path: root/src/showfoto/setup/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2024-12-01 10:36:36 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2024-12-16 20:53:31 +0900
commit394069e6de4326fd15a603fd0598d2de0c3342cd (patch)
tree4d4ab27dd03e368ac479271e707550457d7205e4 /src/showfoto/setup/CMakeLists.txt
parent67fd8bef19878c6940d48fbdafe07a8842c99fd1 (diff)
downloaddigikam-feat/cmake-conversion.tar.gz
digikam-feat/cmake-conversion.zip
Conversion to cmake building systemfeat/cmake-conversion
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'src/showfoto/setup/CMakeLists.txt')
-rw-r--r--src/showfoto/setup/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/showfoto/setup/CMakeLists.txt b/src/showfoto/setup/CMakeLists.txt
new file mode 100644
index 00000000..3755aa43
--- /dev/null
+++ b/src/showfoto/setup/CMakeLists.txt
@@ -0,0 +1,12 @@
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/src/utilities/setup
+)
+
+
+##### showfotosetupinternal library (static)
+
+tde_add_library( showfotosetupinternal STATIC_PIC AUTOMOC
+ SOURCES setup.cpp setupeditor.cpp setuptooltip.cpp
+ LINK showfotosetup-static
+)