summaryrefslogtreecommitdiffstats
path: root/digikam/utilities/imageeditor/tools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'digikam/utilities/imageeditor/tools/Makefile.am')
-rw-r--r--digikam/utilities/imageeditor/tools/Makefile.am19
1 files changed, 19 insertions, 0 deletions
diff --git a/digikam/utilities/imageeditor/tools/Makefile.am b/digikam/utilities/imageeditor/tools/Makefile.am
new file mode 100644
index 0000000..d49ced0
--- /dev/null
+++ b/digikam/utilities/imageeditor/tools/Makefile.am
@@ -0,0 +1,19 @@
+METASOURCES = AUTO
+
+noinst_LTLIBRARIES = libdimgeditortools.la
+
+libdimgeditortools_la_SOURCES = imageresize.cpp imageprint.cpp
+
+libdimgeditortools_la_LDFLAGS = $(all_libraries) $(KDE_RPATH) $(LIB_KDEPRINT)
+
+INCLUDES= -I$(top_srcdir)/digikam/digikam \
+ -I$(top_srcdir)/digikam/libs/dimg \
+ -I$(top_srcdir)/digikam/libs/dimg/filters \
+ -I$(top_srcdir)/digikam/libs/dmetadata \
+ -I$(top_srcdir)/digikam/libs/widgets/common \
+ -I$(top_srcdir)/digikam/libs/greycstoration \
+ -I$(top_srcdir)/digikam/utilities/imageeditor/canvas \
+ -I$(top_srcdir)/digikam/utilities/imageeditor/editor \
+ $(LIBKDCRAW_CFLAGS) \
+ $(all_includes)
+