summaryrefslogtreecommitdiffstats
path: root/src/libs/dialogs/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/libs/dialogs/CMakeLists.txt')
-rw-r--r--src/libs/dialogs/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/libs/dialogs/CMakeLists.txt b/src/libs/dialogs/CMakeLists.txt
new file mode 100644
index 00000000..6d80a8a8
--- /dev/null
+++ b/src/libs/dialogs/CMakeLists.txt
@@ -0,0 +1,36 @@
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/src/libs/dimg/filters
+ ${CMAKE_SOURCE_DIR}/src/libs/thumbbar
+ ${CMAKE_SOURCE_DIR}/src/libs/widgets/common
+ ${CMAKE_SOURCE_DIR}/src/libs/widgets/metadata
+ ${CMAKE_SOURCE_DIR}/src/libs/widgets/iccprofiles
+ ${CMAKE_SOURCE_DIR}/src/libs/widgets/imageplugins
+ ${CMAKE_SOURCE_DIR}/src/utilities/imageeditor/canvas
+)
+
+
+##### dialog library (static)
+
+tde_add_library( dialog STATIC_PIC AUTOMOC
+ SOURCES
+ deletedialogbase.ui imagedialog.cpp rawcameradlg.cpp iccprofileinfodlg.cpp
+ deletedialog.cpp dprogressdlg.cpp
+ LINK
+ tdecore-shared
+)
+
+##### dialogshowfoto library (static)
+
+tde_add_library( dialogshowfoto STATIC_PIC AUTOMOC
+ SOURCES iccprofileinfodlg.cpp imagedialog.cpp rawcameradlg.cpp
+ LINK tdecore-shared
+)
+
+
+##### other files
+
+install(
+ FILES iccprofileinfodlg.h dprogressdlg.h imagedialog.h rawcameradlg.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/${PROJECT_NAME}
+)