summaryrefslogtreecommitdiffstats
path: root/src/libs/dimg/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/libs/dimg/CMakeLists.txt')
-rw-r--r--src/libs/dimg/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/src/libs/dimg/CMakeLists.txt b/src/libs/dimg/CMakeLists.txt
new file mode 100644
index 00000000..5cfb59bb
--- /dev/null
+++ b/src/libs/dimg/CMakeLists.txt
@@ -0,0 +1,29 @@
+include_directories(
+ ${CMAKE_CURRENT_SOURCE_DIR}/filters
+ ${CMAKE_CURRENT_SOURCE_DIR}/loaders
+)
+
+
+##### subfolders
+
+add_subdirectory( loaders )
+add_subdirectory( filters )
+
+
+##### dimg library (static)
+
+tde_add_library( dimg STATIC_PIC
+ SOURCES dimg.cpp dimgscale.cpp dcolor.cpp dcolorcomposer.cpp ddebug.cpp
+ LINK
+ histogram-static levels-static curves-static whitebalance-static
+ dimgloaders-static dimgfilters-static dmetadata-static
+ tdecore-shared ${KDCRAW_LIBRARIES} ${LCMS_LIBRARIES}
+)
+
+
+##### other files
+
+install(
+ FILES dimg.h dcolor.h dcolorpixelaccess.h dcolorcomposer.h dcolorblend.h ddebug.h
+ DESTINATION ${INCLUDE_INSTALL_DIR}/${PROJECT_NAME}
+)