summaryrefslogtreecommitdiffstats
path: root/src/themedesigner/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/themedesigner/CMakeLists.txt')
-rw-r--r--src/themedesigner/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/themedesigner/CMakeLists.txt b/src/themedesigner/CMakeLists.txt
new file mode 100644
index 00000000..1cdd4a74
--- /dev/null
+++ b/src/themedesigner/CMakeLists.txt
@@ -0,0 +1,17 @@
+include_directories(
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}/src/libs/imageproperties
+ ${CMAKE_SOURCE_DIR}/src/libs/themeengine
+ ${CMAKE_SOURCE_DIR}/src/libs/widgets/common
+)
+
+
+##### digikamthemedesigner (executable)
+
+tde_add_executable( digikamthemedesigner AUTOMOC
+ SOURCES
+ main.cpp mainwindow.cpp themedicongroupitem.cpp themediconitem.cpp themediconview.cpp
+ LINK
+ digikam-shared tdecore-shared tdeui-shared ${KDCRAW_LIBRARIES} ${KEXIV2_LIBRARIES}
+ DESTINATION ${BIN_INSTALL_DIR}
+)