summaryrefslogtreecommitdiffstats
path: root/src/utilities/hotplug/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/utilities/hotplug/CMakeLists.txt')
-rw-r--r--src/utilities/hotplug/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/src/utilities/hotplug/CMakeLists.txt b/src/utilities/hotplug/CMakeLists.txt
new file mode 100644
index 00000000..6a28c3a4
--- /dev/null
+++ b/src/utilities/hotplug/CMakeLists.txt
@@ -0,0 +1,19 @@
+configure_file( digikam-download.desktop.cmake digikam-download.desktop @ONLY )
+configure_file( digikam-gphoto2-camera.desktop.cmake digikam-gphoto2-camera.desktop @ONLY )
+configure_file( digikam-mount-and-download.desktop.cmake digikam-mount-and-download.desktop @ONLY )
+
+
+##### other files
+
+install(
+ FILES digikam-camera
+ DESTINATION ${DATA_INSTALL_DIR}/${PROJECT_NAME}/utils
+)
+
+tde_create_translated_desktop(
+ SOURCE
+ ${CMAKE_CURRENT_BINARY_DIR}/digikam-download.desktop
+ ${CMAKE_CURRENT_BINARY_DIR}/digikam-gphoto2-camera.desktop
+ ${CMAKE_CURRENT_BINARY_DIR}/digikam-mount-and-download.desktop
+ DESTINATION ${DATA_INSTALL_DIR}/konqueror/servicemenus
+)