summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-12-23 02:03:40 +0100
committerSlávek Banko <slavek.banko@axis.cz>2018-12-23 02:49:39 +0100
commitb91d8792968cac7b277e9566a7d7b0a8006d8fac (patch)
treed03ac9a7d946dc4c74e00aee8236fe153fb477e3 /po/CMakeLists.txt
parent169d30ec92e54e9454d777e45b943ae161f7d830 (diff)
downloadfilelight-b91d8792968cac7b277e9566a7d7b0a8006d8fac.tar.gz
filelight-b91d8792968cac7b277e9566a7d7b0a8006d8fac.zip
Add CMakeL10n rules.
Create translation template. Modify CMake rules for translations to make them independent of languages. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 0816faa34e96a24644d9cf030cb05a78e71db3b6)
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
index 03be086..2ce6ef4 100644
--- a/po/CMakeLists.txt
+++ b/po/CMakeLists.txt
@@ -1,3 +1,9 @@
-# This file is genereted by trinity-automake-cmake-convert script by Fat-Zer
+# build translations if some are already available
-tde_auto_add_subdirectories( )
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} ${PROJECT_NAME}.po )
+
+foreach( _po ${po_files} )
+ string( REPLACE "/" ";" _path "${_po}" )
+ list( GET _path 0 _lang )
+ tde_create_translation( FILES ${_po} LANG ${_lang} )
+endforeach( )