summaryrefslogtreecommitdiffstats
path: root/translations/messages/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-04-04 19:59:50 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-04-04 20:00:18 +0200
commit7e6b5127982acb4e318fc98bb5b5e711e5746ce5 (patch)
tree22131fe68aedd1a76a16da63bd49c1bff3829fd6 /translations/messages/CMakeLists.txt
parent274f9be9365f7bf244a3150c971bc2ee94185cf2 (diff)
downloadfilelight-7e6b5127982acb4e318fc98bb5b5e711e5746ce5.tar.gz
filelight-7e6b5127982acb4e318fc98bb5b5e711e5746ce5.zip
Move translations to a new directory layout.
Add support for LINGUAS for listing translations to install. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 8e90c28fb2501009f259a084bb2e30388ab8e85e)
Diffstat (limited to 'translations/messages/CMakeLists.txt')
-rw-r--r--translations/messages/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/translations/messages/CMakeLists.txt b/translations/messages/CMakeLists.txt
new file mode 100644
index 0000000..75c89f8
--- /dev/null
+++ b/translations/messages/CMakeLists.txt
@@ -0,0 +1,14 @@
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
+string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
+
+foreach( _po ${po_files} )
+ get_filename_component( _lang ${_po} NAME_WE )
+ if( "${_linguas}" MATCHES "^;*$" OR ";${_linguas};" MATCHES ";${_lang};" )
+ if( "${_po}" MATCHES "^([^/]*)/.*" )
+ string( REGEX REPLACE "^([^/]*)/.*" "\\1" _component "${_po}" )
+ else( )
+ set( _component "${PROJECT_NAME}" )
+ endif( )
+ tde_create_translation( FILES ${_po} LANG ${_lang} OUTPUT_NAME ${_component} )
+ endif( )
+endforeach( )