summaryrefslogtreecommitdiffstats
path: root/src/gvdirpart/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gvdirpart/Makefile.am')
-rw-r--r--src/gvdirpart/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/gvdirpart/Makefile.am b/src/gvdirpart/Makefile.am
new file mode 100644
index 0000000..039267d
--- /dev/null
+++ b/src/gvdirpart/Makefile.am
@@ -0,0 +1,23 @@
+INCLUDES = -I$(srcdir)/.. $(all_includes)
+
+# These are not really libraries, but modules dynamically opened.
+# So they should be installed in kde_module_dir, which is usually $kde_prefix/lib/kde3
+kde_module_LTLIBRARIES = libgvdirpart.la
+
+libgvdirpart_la_SOURCES = gvdirpart.cpp gvdirpartconfig.kcfgc
+libgvdirpart_la_LIBADD = $(LIB_KPARTS) ../gvcore/libgwenviewcore.la
+libgvdirpart_la_LDFLAGS = $(all_libraries) $(KDE_PLUGIN)
+
+# Automatically generate moc files
+METASOURCES = AUTO
+
+# Install the XML-GUI file to its correct location
+gvdir = $(kde_datadir)/gvdirpart
+gv_DATA = gvdirpart.rc
+
+# Install the .desktop file into the kde_services directory
+kde_services_DATA = gvdirpart.desktop
+
+KDE_ICON = AUTO
+
+kde_kcfg_DATA = gvdirpartconfig.kcfg