summaryrefslogtreecommitdiffstats
path: root/k9decmpeg/Makefile.am
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2023-08-06 01:07:46 +0200
committerSlávek Banko <slavek.banko@axis.cz>2023-08-06 09:23:43 +0200
commit0984c8a873d7ed24259cf1ba600a3c989cdb3b08 (patch)
tree35c942467312c2e4ffd3d654917e9579503f3702 /k9decmpeg/Makefile.am
parentba09a974bad106c61008615fb86deffe26f32bd3 (diff)
downloadk9copy-0984c8a873d7ed24259cf1ba600a3c989cdb3b08.tar.gz
k9copy-0984c8a873d7ed24259cf1ba600a3c989cdb3b08.zip
Fix incorrect use of dvdread includes.
It seems that the library has been designed for use includes in the form "#include <dvdread/...>" while we used includes without the "dvdread/" prefix. This caused that instead of using the standard path detected from pkg-config, the expected path had to be added to to -I flag. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 9f7c0362e26f62dc81769ab55a89e32c3c9a268d)
Diffstat (limited to 'k9decmpeg/Makefile.am')
-rw-r--r--k9decmpeg/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/k9decmpeg/Makefile.am b/k9decmpeg/Makefile.am
index 1d8911f..c47f0e4 100644
--- a/k9decmpeg/Makefile.am
+++ b/k9decmpeg/Makefile.am
@@ -12,7 +12,7 @@ libk9decmpeg_la_SOURCES = alloc.cpp attributes.h bswap.h convert_internal.h \
motion_comp_altivec.cpp motion_comp.cpp motion_comp_mmx.cpp motion_comp_vis.cpp mpeg2convert.h \
mpeg2.h mpeg2_internal.h rgb.cpp rgb_mmx.cpp rgb_vis.cpp slice.cpp tendra.h \
uyvy.cpp video_out.h vis.h vlc.h k9decodethread.cpp k9plaympeg2.cpp
-INCLUDES = -I/usr/include/dvdread -I$(top_srcdir)/k9vamps \
+INCLUDES = -I$(top_srcdir)/k9vamps \
-I$(top_srcdir)/libdvdnav -I$(top_srcdir)/libk9copy
noinst_HEADERS = k9decodethread.h k9plaympeg2.h