summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-06-05 15:35:30 +0200
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-06-06 18:15:42 +0900
commit879d11940771d832e987da215de9f0f396786a3f (patch)
tree0dfc1203b24de78dc4ed21333c85cd5604988e8e /CMakeLists.txt
parent3d4cc752db088f4f692d7422a29b4c534add17e4 (diff)
downloadkasablanca-879d11940771d832e987da215de9f0f396786a3f.tar.gz
kasablanca-879d11940771d832e987da215de9f0f396786a3f.zip
Drop automake build support.
Add basic cmake build instructions. Delete empty file NEWS and rpm spec files. Better detection for OpenSSL headers and libraries. Write a README file. Rework of the help page. Some cosmetics. Signed-off-by: gregory guy <gregory-tde@laposte.net> (cherry picked from commit 11c5062539a42b939727a3f0f8a6fbacc1b238be)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6ae9a2d..464019f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,15 +41,15 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules
-option( BUILD_ALL "Build all" ON )
-option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
-option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+option( BUILD_ALL "Build all" ON )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
##### configure checks
@@ -69,7 +69,7 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( src )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )