summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-04-12 02:30:13 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-04-12 09:22:20 +0200
commit0d2238b5a78bc1aa5440b0ce63f83249aafc40c2 (patch)
tree05a43d362cff263b3f307774ba9bf6eca6187910 /CMakeLists.txt
parent903ee205e515f879deacfe7e08c157528d6a14b5 (diff)
downloadkasablanca-0d2238b5a78bc1aa5440b0ce63f83249aafc40c2.tar.gz
kasablanca-0d2238b5a78bc1aa5440b0ce63f83249aafc40c2.zip
Added controlled conversions to char* instead of automatic ascii conversions.
The definition of -UTQT_NO_ASCII_CAST is no longer needed. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bcbe256..171828c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -59,7 +59,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings
-add_definitions( -DHAVE_CONFIG_H -UTQT_NO_ASCII_CAST )
+add_definitions( -DHAVE_CONFIG_H )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )