summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-30 22:12:53 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-30 22:13:10 +0200
commitda4d37d1e1f66c370a3d3fe5ef43cffaf3663aef (patch)
tree1558866435ddb59e66c4afdaecdbe64807c30166 /CMakeLists.txt
parentedba9b4ca2babb8c1c0bc287d87466e5a92e9919 (diff)
downloadkbarcode-da4d37d1e1f66c370a3d3fe5ef43cffaf3663aef.tar.gz
kbarcode-da4d37d1e1f66c370a3d3fe5ef43cffaf3663aef.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 682540075e11a775319b37bc443ad69ebec1b00b)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index eff7924..fb08f4e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -73,8 +73,12 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
add_subdirectory( ${PROJECT_NAME} )
add_subdirectory( fileplugin )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files