summaryrefslogtreecommitdiffstats
path: root/kbfx.ebuild.in
diff options
context:
space:
mode:
Diffstat (limited to 'kbfx.ebuild.in')
-rw-r--r--kbfx.ebuild.in31
1 files changed, 31 insertions, 0 deletions
diff --git a/kbfx.ebuild.in b/kbfx.ebuild.in
new file mode 100644
index 0000000..2eb54c3
--- /dev/null
+++ b/kbfx.ebuild.in
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header
+
+inherit kde eutils
+need-kde 3.3
+
+MY_PN="${PN}-@VERSION@"
+S="${WORKDIR}/${MY_PN}"
+
+DESCRIPTION="KDE alternative K-Menu"
+HOMEPAGE="http://www.kbfx.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_PN}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="@GENTOO_KEYWORDS@"
+IUSE="strigi"
+
+DEPEND=">=dev-util/cmake-2.4.2
+ strigi? ( kde-misc/strigi )"
+
+export DESTDIR=${D}
+
+src_compile() {
+ cd ${S}
+ cmake \
+ -DCMAKE_INSTALL_PREFIX:PATH=${KDEDIR} \
+ -DUSE_STRIGI:BOOL=$( use strigi && echo ON || echo OFF ) \
+ . || die
+}