summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-12-11 14:26:49 +0100
committerSlávek Banko <slavek.banko@axis.cz>2018-12-11 14:27:08 +0100
commit6d667f4eab84a8f5be67689f469e1f048e604b05 (patch)
tree0b94886cf8c911356fd6128eff067ebb60977d03 /po/CMakeLists.txt
parent41d0cc4d8c07c7c54cb75405553a0b220eb1e164 (diff)
downloadkbiff-6d667f4eab84a8f5be67689f469e1f048e604b05.tar.gz
kbiff-6d667f4eab84a8f5be67689f469e1f048e604b05.zip
Add CMakeL10n rules.
Create translation template. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit c94e47a08b64d2053f9f66ad991734f79d52ce3e)
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
index f5a2e1b..46fba83 100644
--- a/po/CMakeLists.txt
+++ b/po/CMakeLists.txt
@@ -1 +1,6 @@
-tde_create_translation( LANG auto OUTPUT_NAME ${PROJECT_NAME} )
+# build translations if some are already available
+
+file( GLOB _srcs RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
+if( _srcs )
+ tde_create_translation( LANG auto OUTPUT_NAME ${PROJECT_NAME} )
+endif( )