summaryrefslogtreecommitdiffstats
path: root/translations/messages/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-04-05 15:57:25 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-04-05 15:57:43 +0200
commit4c38003eea56e3986a02672ff455946d404495cf (patch)
tree867c28f2b1a122a43caffcc36a3b5f3642f928e9 /translations/messages/CMakeLists.txt
parent057ca4c9ca43c3f64263ac3a0ee213aba8ed3b4f (diff)
downloadkbiff-4c38003eea56e3986a02672ff455946d404495cf.tar.gz
kbiff-4c38003eea56e3986a02672ff455946d404495cf.zip
Move translations to a new directory layout.
Add support for LINGUAS for listing translations to install. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 70c6012735401beda672124d23c06a7b5fe20b72)
Diffstat (limited to 'translations/messages/CMakeLists.txt')
-rw-r--r--translations/messages/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/translations/messages/CMakeLists.txt b/translations/messages/CMakeLists.txt
new file mode 100644
index 0000000..75c89f8
--- /dev/null
+++ b/translations/messages/CMakeLists.txt
@@ -0,0 +1,14 @@
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
+string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
+
+foreach( _po ${po_files} )
+ get_filename_component( _lang ${_po} NAME_WE )
+ if( "${_linguas}" MATCHES "^;*$" OR ";${_linguas};" MATCHES ";${_lang};" )
+ if( "${_po}" MATCHES "^([^/]*)/.*" )
+ string( REGEX REPLACE "^([^/]*)/.*" "\\1" _component "${_po}" )
+ else( )
+ set( _component "${PROJECT_NAME}" )
+ endif( )
+ tde_create_translation( FILES ${_po} LANG ${_lang} OUTPUT_NAME ${_component} )
+ endif( )
+endforeach( )