summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c94156e..a593098 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -42,6 +42,8 @@ tde_setup_paths( )
option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+option( WITH_SSL "Build with SSL (imap4s and pop3s) protocol support" ${WITH_ALL_OPTIONS} )
+option( WITH_MLED "Compile with support for Mail LED on ASUS notebooks" OFF )
##### user requested modules
@@ -51,6 +53,11 @@ option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+##### user defined options #######
+
+set( _PATH_MAILDIR "/var/spool/mail" CACHE STRING "Path for the mail spool" )
+
+
##### configure checks
include( ConfigureChecks.cmake )