summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-05-11 17:41:22 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-05-12 17:38:30 +0200
commit518045aebbfa9cf4cd1f9f4b36d5003f2414795e (patch)
treea4f0888ef3228dab49d298b0bd1f19e0001382dd /CMakeLists.txt
parent87aa164bb841a8ffe4f418f14f861b16a6780003 (diff)
downloadkchmviewer-518045aebbfa9cf4cd1f9f4b36d5003f2414795e.tar.gz
kchmviewer-518045aebbfa9cf4cd1f9f4b36d5003f2414795e.zip
Added controlled conversions to char* instead of automatic ascii conversions.
The definition of -UTQT_NO_ASCII_CAST is no longer needed. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit c0263d89c688f750a6e68a7f77257b2be0c55990)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 09c7b7d..308898b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -61,7 +61,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings
-add_definitions( -DHAVE_CONFIG_H -UQT_NO_ASCII_CAST )
+add_definitions( -DHAVE_CONFIG_H )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )