summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-06-21 11:37:26 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-06-21 11:37:55 +0200
commitbff2c03daf5e15c00e2c45cd56efe2df37ec5958 (patch)
tree822e477ab455372a1813a004254fadb490a71cfc /CMakeLists.txt
parentf724e418b821bde4a8c659df4aadbc7733abc634 (diff)
downloadkdbusnotification-bff2c03daf5e15c00e2c45cd56efe2df37ec5958.tar.gz
kdbusnotification-bff2c03daf5e15c00e2c45cd56efe2df37ec5958.zip
Add translations for the daemon as such.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 3d7a0102b1abb948396b5c5c82aace91c4c0f22c)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 954f081..0ca47c7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -45,6 +45,12 @@ option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+##### user requested modules #####
+
+option( BUILD_ALL "Build all" ON )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+
+
##### configure checks
include( ConfigureChecks.cmake )
@@ -62,6 +68,7 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( src )
+tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
##### write configure files