summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in166
1 files changed, 0 insertions, 166 deletions
diff --git a/configure.in b/configure.in
deleted file mode 100644
index e03ff17..0000000
--- a/configure.in
+++ /dev/null
@@ -1,166 +0,0 @@
-dnl =======================================================
-dnl FILE: ./admin/configure.in.min
-dnl =======================================================
-
-dnl This file is part of the KDE libraries/packages
-dnl Copyright (C) 2001 Stephan Kulow (coolo@kde.org)
-
-dnl This file is free software; you can redistribute it and/or
-dnl modify it under the terms of the GNU Library General Public
-dnl License as published by the Free Software Foundation; either
-dnl version 2 of the License, or (at your option) any later version.
-
-dnl This library is distributed in the hope that it will be useful,
-dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
-dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-dnl Library General Public License for more details.
-
-dnl You should have received a copy of the GNU Library General Public License
-dnl along with this library; see the file COPYING.LIB. If not, write to
-dnl the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
-dnl Boston, MA 02110-1301, USA.
-
-# Original Author was Kalle@kde.org
-# I lifted it in some mater. (Stephan Kulow)
-# I used much code from Janos Farkas
-
-dnl Process this file with autoconf to produce a configure script.
-
-AC_INIT(acinclude.m4) dnl a source file from your sub dir
-
-dnl This is so we can use kde-common
-AC_CONFIG_AUX_DIR(admin)
-
-dnl This ksh/zsh feature conflicts with `cd blah ; pwd`
-unset CDPATH
-
-dnl Checking host/target/build systems, for make, install etc.
-AC_CANONICAL_SYSTEM
-dnl Perform program name transformation
-AC_ARG_PROGRAM
-
-dnl Automake doc recommends to do this only here. (Janos)
-AM_INIT_AUTOMAKE(kdiff3, 0.9.92) dnl searches for some needed programs
-
-KDE_SET_PREFIX
-
-dnl generate the config header
-AM_CONFIG_HEADER(config.h) dnl at the distribution this done
-
-dnl Checks for programs.
-AC_CHECK_COMPILERS
-AC_ENABLE_SHARED(yes)
-AC_ENABLE_STATIC(no)
-KDE_PROG_LIBTOOL
-
-dnl for NLS support. Call them in this order!
-dnl WITH_NLS is for the po files
-AM_KDE_WITH_NLS
-
-KDE_USE_QT(3.2)
-AC_PATH_KDE
-dnl =======================================================
-dnl FILE: configure.in.in
-dnl =======================================================
-
-#MIN_CONFIG(3.2)
-
-###################################################
-# Check for Konqueror (copied from krusader-1.70)
-###################################################
-
-AC_ARG_WITH(konqueror,
- AC_HELP_STRING([--without-konqueror],[build KDiff3 without support Konqueror's servicemenus [default=with]]),
- [with_konq=$withval],
- [with_konq=yes]
-)
-
-if test "$with_konq" != "no"; then
- # check for the headers
- have_libkonq=yes
- KDE_CHECK_HEADER(konq_popupmenu.h, ,[have_libkonq=no] )
-
- if test "$have_libkonq" = "no"; then
- # if this var is 'yes', the configure-suppery drops a warning.
- # see admin/configure.in.bot.end
- warn_konq=yes
- fi
-fi
-
-if test "$have_libkonq" != "yes"; then
- DO_NOT_COMPILE="$DO_NOT_COMPILE kdiff3plugin"
-fi
-
-AM_CONDITIONAL(include_libkonq, test "$have_libkonq" = yes)
-
-dnl PACKAGE set before
-AC_C_BIGENDIAN
-AC_CHECK_KDEMAXPATHLEN
-
-KDE_CREATE_SUBDIRSLIST
-AC_CONFIG_FILES([ Makefile ])
-AC_CONFIG_FILES([ doc/Makefile ])
-AC_CONFIG_FILES([ doc/da/Makefile ])
-AC_CONFIG_FILES([ doc/de/Makefile ])
-AC_CONFIG_FILES([ doc/en/Makefile ])
-AC_CONFIG_FILES([ doc/es/Makefile ])
-AC_CONFIG_FILES([ doc/et/Makefile ])
-AC_CONFIG_FILES([ doc/fr/Makefile ])
-AC_CONFIG_FILES([ doc/it/Makefile ])
-AC_CONFIG_FILES([ doc/nl/Makefile ])
-AC_CONFIG_FILES([ doc/pt/Makefile ])
-AC_CONFIG_FILES([ doc/sv/Makefile ])
-AC_CONFIG_FILES([ kdiff3plugin/Makefile ])
-AC_CONFIG_FILES([ kdiff3plugin/po/Makefile ])
-AC_CONFIG_FILES([ po/Makefile ])
-AC_CONFIG_FILES([ src/Makefile ])
-AC_OUTPUT
-# Check if KDE_SET_PREFIX was called, and --prefix was passed to configure
-if test -n "$kde_libs_prefix" -a -n "$given_prefix"; then
- # And if so, warn when they don't match
- if test "$kde_libs_prefix" != "$given_prefix"; then
- # And if kde doesn't know about the prefix yet
- echo ":"`tde-config --path exe`":" | grep ":$given_prefix/bin/:" 2>&1 >/dev/null
- if test $? -ne 0; then
- echo ""
- echo "Warning: you chose to install this package in $given_prefix,"
- echo "but KDE was found in $kde_libs_prefix."
- echo "For this to work, you will need to tell KDE about the new prefix, by ensuring"
- echo "that TDEDIRS contains it, e.g. export TDEDIRS=$given_prefix:$kde_libs_prefix"
- echo "Then restart KDE."
- echo ""
- fi
- fi
-fi
-
-if test x$GXX = "xyes" -a x$kde_have_gcc_visibility = "xyes" -a x$kde_cv_val_qt_gcc_visibility_patched = "xno"; then
- echo ""
- echo "Your GCC supports symbol visibility, but the patch for Qt supporting visibility"
- echo "was not included. Therefore, GCC symbol visibility support remains disabled."
- echo ""
- echo "For better performance, consider including the Qt visibility supporting patch"
- echo "located at:"
- echo ""
- echo "http://bugs.kde.org/show_bug.cgi?id=109386"
- echo ""
- echo "and recompile all of Qt and KDE. Note, this is entirely optional and"
- echo "everything will continue to work just fine without it."
- echo ""
-fi
-
-if (test $warn_konq);
- then echo "NOTICE: Since the Konqueror-headers were not found KDiff3 will be built without support for its service-menus and the KDiff3-service menu will not be built. (Install the package containing konq_popupmenu.h. Possibly tdebase-devel or on Debian libkonq4-dev etc.)"
-fi
-
-if test "$all_tests" = "bad"; then
- if test ! "$cache_file" = "/dev/null"; then
- echo ""
- echo "Please remove the file $cache_file after changing your setup"
- echo "so that configure will find the changes next time."
- echo ""
- fi
-else
- echo ""
- echo "Good - your configure finished. Start make now"
- echo ""
-fi