summaryrefslogtreecommitdiffstats
path: root/kdpkg-install/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kdpkg-install/Makefile.am')
-rw-r--r--kdpkg-install/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/kdpkg-install/Makefile.am b/kdpkg-install/Makefile.am
new file mode 100644
index 0000000..c0ed3d9
--- /dev/null
+++ b/kdpkg-install/Makefile.am
@@ -0,0 +1,32 @@
+# set the include path for X, qt and KDE
+AM_CPPFLAGS = $(all_includes)
+
+# these are the headers for your project
+noinst_HEADERS = install.h console.h
+
+# let automoc handle all of the meta source files (moc)
+METASOURCES = AUTO
+
+# the application source, library search path, and link libraries
+kdpkg_install_SOURCES = main.cpp install.cpp installdialog.ui process.cpp console.cpp consoledialog.ui
+kdpkg_install_LDFLAGS = $(KDE_RPATH) $(all_libraries)
+kdpkg_install_LDADD = $(LIB_KDEUI)
+
+
+# application
+xdg_apps_DATA = kdpkg-install.desktop
+bin_PROGRAMS = kdpkg-install
+
+sharedir = $(pkgdatadir)
+install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(sharedir)
+ cp -aR $(srcdir)/icons $(DESTDIR)$(sharedir)/
+ cp -aR $(srcdir)/sh $(DESTDIR)$(sharedir)/
+
+
+
+# translation
+messages: rc.cpp
+ $(EXTRACTRC) `find . -name \*.ui -o -name \*.rc` > rc.cpp
+ $(XGETTEXT) *.cpp -o $(podir)/kdpkg-install.pot
+