summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <gregory-tde@laposte.net>2020-07-28 17:14:45 +0200
committerMichele Calgaro <michele.calgaro@yahoo.it>2020-07-29 13:27:36 +0900
commit269e24133f33fddf5c512f1316a6b97936a94e54 (patch)
tree5ec573cb1d788d79c53f4fdb9fee59a5cdd47610 /CMakeLists.txt
parent267743ac8c37b34340417b7d2281bbd8f3a1aa35 (diff)
downloadkeep-269e24133f33fddf5c512f1316a6b97936a94e54.tar.gz
keep-269e24133f33fddf5c512f1316a6b97936a94e54.zip
Drop automake build support.
Add basic cmake build instructions. Rework of the README file. Delete files INDEX and Mainpage.dox. Add a warning if the rdiff-backup backend is not found on the system. Some cosmetics. Signed-off-by: gregory guy <gregory-tde@laposte.net> (cherry picked from commit d60abd172dca3ed096aee7e34c75b0d43673816e)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 68d9731..6a3f67f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -41,15 +41,15 @@ tde_setup_paths( )
##### optional stuff
-option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
##### user requested modules
-option( BUILD_ALL "Build all" ON )
-option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
-option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+option( BUILD_ALL "Build all" ON )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
##### configure checks
@@ -69,7 +69,7 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( ${PROJECT_NAME} )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )