summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2021-07-30 22:41:29 +0200
committerSlávek Banko <slavek.banko@axis.cz>2021-07-30 22:41:49 +0200
commit566463a7a0e28a67d24850c4c0f908edb996a35f (patch)
treeef6d69a738bd0c3c2cfaf8a3d30bc7ae038ade8a /CMakeLists.txt
parent5c47a18ac60388a5adaf7f5eafab3ac414d0cb5c (diff)
downloadkeep-566463a7a0e28a67d24850c4c0f908edb996a35f.tar.gz
keep-566463a7a0e28a67d24850c4c0f908edb996a35f.zip
Use common rules for build and install documentation and translations.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 80833d85844b784609e68dea15ccedea6d870f39)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 00ae1c1..54432c7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -69,8 +69,12 @@ set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined"
##### directories
add_subdirectory( ${PROJECT_NAME} )
-tde_conditional_add_subdirectory( BUILD_DOC doc )
-tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
+
+
+##### other data ################################
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_project_translations( BUILD_TRANSLATIONS )
##### write configure files