summaryrefslogtreecommitdiffstats
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-07-29 09:24:19 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-07-29 09:25:28 +0200
commit7daefc3cd4f5c6a32da58a46754d387e8f7d7ca9 (patch)
treeeb0796ea20894c7a65e35d9eca251d69fb4fc80e /doc/CMakeLists.txt
parent269e24133f33fddf5c512f1316a6b97936a94e54 (diff)
downloadkeep-7daefc3cd4f5c6a32da58a46754d387e8f7d7ca9.tar.gz
keep-7daefc3cd4f5c6a32da58a46754d387e8f7d7ca9.zip
Move translations to a new directory layout.
Add support for LINGUAS for listing translations to install. Use common cmake rules for documentation. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit f53b2baa8e571d46f0c3f38da20ddd1c243063c2)
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt35
1 files changed, 34 insertions, 1 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index 6d0aa9f..f6eec15 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -1 +1,34 @@
-tde_auto_add_subdirectories( )
+file( GLOB _dirs RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} * )
+list( REMOVE_ITEM _dirs html man )
+
+string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
+
+foreach( _dir IN LISTS _dirs )
+ if( IS_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/${_dir}
+ AND ( "${_dir}" STREQUAL "en" OR
+ "${_linguas}" MATCHES "^;*$" OR
+ ";${_linguas};" MATCHES ";${_dir};" ))
+ file( GLOB _doc_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}/${_dir} ${_dir}/*.docbook )
+ if( _doc_files )
+ list( FIND _doc_files "index.docbook" _find_index )
+ if( -1 EQUAL _find_index )
+ set( _noindex "NOINDEX" )
+ else()
+ unset( _noindex )
+ endif()
+ tde_create_handbook(
+ SOURCE_BASEDIR ${_dir}
+ ${_noindex}
+ LANG ${_dir}
+ DESTINATION ${PROJECT_NAME}
+ )
+ endif()
+ endif()
+endforeach()
+
+if( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/html/CMakeLists.txt )
+ add_subdirectory( html )
+endif()
+if( EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/man/CMakeLists.txt )
+ add_subdirectory( man )
+endif()