summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <g-gregory@gmx.fr>2019-05-19 19:22:18 +0200
committerSlávek Banko <slavek.banko@axis.cz>2019-05-23 17:03:40 +0200
commitde29a16353e533a9bfa9414eff45bb8e7c36da32 (patch)
treee225748a5c51ba331460db2c57a95b43c04a073a /po/CMakeLists.txt
parent470c6e294f76313714322b7ffc586fe4479f2fd5 (diff)
downloadkeep-de29a16353e533a9bfa9414eff45bb8e7c36da32.tar.gz
keep-de29a16353e533a9bfa9414eff45bb8e7c36da32.zip
conversion to the cmake building system
Signed-off-by: gregory guy <g-gregory@gmx.fr> (cherry picked from commit 14bb845a29befcb8b11e2b55a43c58684d9acac0)
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
new file mode 100644
index 0000000..e3b5278
--- /dev/null
+++ b/po/CMakeLists.txt
@@ -0,0 +1,7 @@
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} ${PROJECT_NAME}.po )
+
+foreach( _po ${po_files} )
+ string( REPLACE "/" ";" _path "${_po}" )
+ list( GET _path 0 _lang )
+ tde_create_translation( FILES ${_po} LANG ${_lang} )
+endforeach( )