summaryrefslogtreecommitdiffstats
path: root/po/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <g-gregory@gmx.fr>2019-05-19 19:22:18 +0200
committergregory guy <g-gregory@gmx.fr>2019-05-19 19:22:18 +0200
commit14bb845a29befcb8b11e2b55a43c58684d9acac0 (patch)
treea16035ab2089d9313ec91502cabe161e5d31e1f3 /po/CMakeLists.txt
parent2663b431fc4f6e40655367b67ae6345f4f839ccf (diff)
downloadkeep-14bb845a29befcb8b11e2b55a43c58684d9acac0.tar.gz
keep-14bb845a29befcb8b11e2b55a43c58684d9acac0.zip
conversion to the cmake building system
Signed-off-by: gregory guy <g-gregory@gmx.fr>
Diffstat (limited to 'po/CMakeLists.txt')
-rw-r--r--po/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/po/CMakeLists.txt b/po/CMakeLists.txt
new file mode 100644
index 0000000..e3b5278
--- /dev/null
+++ b/po/CMakeLists.txt
@@ -0,0 +1,7 @@
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} ${PROJECT_NAME}.po )
+
+foreach( _po ${po_files} )
+ string( REPLACE "/" ";" _path "${_po}" )
+ list( GET _path 0 _lang )
+ tde_create_translation( FILES ${_po} LANG ${_lang} )
+endforeach( )