summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2022-03-18 04:03:50 +0100
committerSlávek Banko <slavek.banko@axis.cz>2022-03-20 18:50:59 +0100
commit5ec229a4470f605eca53326853ff246a49e80189 (patch)
tree5b40a3f1189bdd4307d903f13235fe6ba7081c46 /CMakeLists.txt
parent49e34b02b0bb609ce6e9ff1d2d96bdfcb03617d1 (diff)
downloadkmymoney-5ec229a4470f605eca53326853ff246a49e80189.tar.gz
kmymoney-5ec229a4470f605eca53326853ff246a49e80189.zip
Enforce the use of TQt with STL only where it is necessary.
The definition of -UTQT_NO_STL is no longer needed. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit f3fd991c693316d26e360438eff8ecff8a54553d)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 487e6b1..86062b9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,7 +66,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings
-add_definitions( -DHAVE_CONFIG_H -UQT_NO_STL )
+add_definitions( -DHAVE_CONFIG_H )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )