summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2022-03-17 09:54:21 +0100
committerSlávek Banko <slavek.banko@axis.cz>2022-03-20 18:50:15 +0100
commita553069ad068dcab541282df24dbe12591153af8 (patch)
tree6e0b3fc71e22d976fe434da0deab1a1fe0117476 /CMakeLists.txt
parentfebacdee5bf580932e1937f656b475762b48acd6 (diff)
downloadkmymoney-a553069ad068dcab541282df24dbe12591153af8.tar.gz
kmymoney-a553069ad068dcab541282df24dbe12591153af8.zip
Replace the use of the old API TQString::data().
The definition of -UTQT_NO_COMPAT is no longer needed. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit eeae53f59df4d79d0399c2217a165ff2fab754db)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6aef1d7..4e22c63 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,7 +66,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings
-add_definitions( -DHAVE_CONFIG_H -UQT_NO_ASCII_CAST -UQT_NO_COMPAT -UQT_NO_STL )
+add_definitions( -DHAVE_CONFIG_H -UQT_NO_ASCII_CAST -UQT_NO_STL )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )