summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2022-03-16 23:34:43 +0100
committerSlávek Banko <slavek.banko@axis.cz>2022-03-18 12:45:23 +0100
commita6454b1658d325d6ff2d6ba6c349b772148798e0 (patch)
tree7301520567c1e8c5396af155b38d9ceb6b71334b /CMakeLists.txt
parentd855f704e838b0bcf33907ff38165fd1f745356b (diff)
downloadkmymoney-a6454b1658d325d6ff2d6ba6c349b772148798e0.tar.gz
kmymoney-a6454b1658d325d6ff2d6ba6c349b772148798e0.zip
Conversion to the cmake building system.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt92
1 files changed, 92 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..32feca8
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,92 @@
+############################################
+# #
+# Improvements and feedbacks are welcome #
+# #
+# This file is released under GPL >= 3 #
+# #
+############################################
+
+
+cmake_minimum_required( VERSION 3.1 )
+
+
+#### general package setup
+
+project( kmymoney2 )
+set( VERSION R14.1.0 )
+set( APP_VERSION 1.0.5 )
+
+
+#### include essential cmake modules
+
+include( FindPkgConfig )
+include( CheckFunctionExists )
+include( CheckSymbolExists )
+include( CheckIncludeFile )
+include( CheckLibraryExists )
+include( CheckCSourceCompiles )
+include( CheckCXXSourceCompiles )
+
+
+#### include our cmake modules
+
+set( CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake/modules" )
+include( TDEMacros )
+include( kmm-macros.cmake )
+
+
+##### setup install paths
+
+include( TDESetupPaths )
+tde_setup_paths( )
+
+
+##### optional stuff
+
+option( WITH_ALL_OPTIONS "Enable all optional support" OFF )
+option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden" ${WITH_ALL_OPTIONS} )
+option( WITH_LIBOFX "Enable support for OFX" ${WITH_ALL_OPTIONS} )
+
+
+##### user requested modules
+
+option( BUILD_ALL "Build all" ON )
+option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
+option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+option( BUILD_DESIGNER_PLUGIN "Build plugin for TQt Designer" ${BUILD_ALL} )
+option( BUILD_DEVELOPER_DOCS "Build developer documentation" ${BUILD_ALL} )
+option( BUILD_PDF_DOCS "Build PDF documentation" ${BUILD_ALL} )
+
+
+##### configure checks
+
+enable_testing( )
+include( ConfigureChecks.cmake )
+
+
+###### global compiler settings
+
+add_definitions( -DHAVE_CONFIG_H -UTQT_NO_ASCII_CAST -UTQT_NO_COMPAT -UTQT_NO_STL )
+
+set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
+set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )
+set( CMAKE_MODULE_LINKER_FLAGS "${CMAKE_MODULE_LINKER_FLAGS} -Wl,--no-undefined" )
+
+
+##### directories
+
+add_subdirectory( kmymoney2 )
+add_subdirectory( libkdchart )
+add_subdirectory( libkgpgfile )
+
+
+##### other data
+
+tde_conditional_add_project_docs( BUILD_DOC )
+tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
+tde_conditional_add_subdirectory( BUILD_DEVELOPER_DOCS developer-doc )
+
+
+##### write configure files
+
+configure_file( config.h.cmake config.h @ONLY )