summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2022-03-18 04:03:50 +0100
committerSlávek Banko <slavek.banko@axis.cz>2022-03-18 12:45:32 +0100
commitf3fd991c693316d26e360438eff8ecff8a54553d (patch)
tree332159ae0e96affb31c831b82e069fbeb1d7984b /CMakeLists.txt
parent5e6c401557744fe5f9765471605cc793939fee1f (diff)
downloadkmymoney-f3fd991c693316d26e360438eff8ecff8a54553d.tar.gz
kmymoney-f3fd991c693316d26e360438eff8ecff8a54553d.zip
Enforce the use of TQt with STL only where it is necessary.
The definition of -UTQT_NO_STL is no longer needed. Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 439d976..c090da2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,7 +66,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings
-add_definitions( -DHAVE_CONFIG_H -UTQT_NO_STL )
+add_definitions( -DHAVE_CONFIG_H )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )