summaryrefslogtreecommitdiffstats
path: root/developer-doc/phb/Makefile.am
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2022-03-16 23:34:43 +0100
committerSlávek Banko <slavek.banko@axis.cz>2022-03-20 18:49:09 +0100
commitfebacdee5bf580932e1937f656b475762b48acd6 (patch)
tree56cf1a5ea34db847036dd71f58e1f9d7b6f128ce /developer-doc/phb/Makefile.am
parent9757aeb46efff389c2b118cb373206d0720235cd (diff)
downloadkmymoney-febacdee5bf580932e1937f656b475762b48acd6.tar.gz
kmymoney-febacdee5bf580932e1937f656b475762b48acd6.zip
Conversion to the cmake building system.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit a6454b1658d325d6ff2d6ba6c349b772148798e0)
Diffstat (limited to 'developer-doc/phb/Makefile.am')
-rw-r--r--developer-doc/phb/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/developer-doc/phb/Makefile.am b/developer-doc/phb/Makefile.am
index 9e38295..f3024e5 100644
--- a/developer-doc/phb/Makefile.am
+++ b/developer-doc/phb/Makefile.am
@@ -19,9 +19,9 @@ STYLESHEET = tde-nochunk.xsl
phb.html: $(DOCBOOK_FILES)
@if test -e $(MEINPROC); then \
- echo $(MEINPROC) --stylesheet $(kde_libs_prefix)/share/apps/ksgmltools2/customization/$(STYLESHEET) $(srcdir)/phb.docbook -o phb.html; \
- echo sed -i "s/ISO-8859-1/UTF-8/g" phb.html; \
- $(MEINPROC) --stylesheet $(kde_libs_prefix)/share/apps/ksgmltools2/customization/$(STYLESHEET) $(srcdir)/phb.docbook --stdout | sed "s/ISO-8859-1/UTF-8/g" > phb.html; \
+ $(MEINPROC) --stylesheet $(kde_libs_prefix)/share/apps/ksgmltools2/customization/$(STYLESHEET) $(srcdir)/phb.docbook --stdout | \
+ iconv -f ISO-8859-1 -t UTF-8 | \
+ sed "s/ISO-8859-1/UTF-8/g" > phb.html; \
fi
preview: phb.html
@@ -106,10 +106,8 @@ if GENERATE_PDF
kmymoney-phb.pdf: $(DOCBOOK_FILES)
$(MAKE) get-files
$(MEINPROC) --stylesheet `dirname $(KDE_XSL_STYLESHEET)`/tde-nochunk.xsl $(srcdir)/phb.docbook -o index.html
- recode utf8..latin1 index.html || :
html2ps -o kmymoney-phb.ps -n index.html
ps2pdf kmymoney-phb.ps kmymoney-phb.pdf
rm index.html kmymoney-phb.ps
$(MAKE) clear-files
endif
-