summaryrefslogtreecommitdiffstats
path: root/kmymoney2/plugins/Makefile.am
diff options
context:
space:
mode:
authorMichele Calgaro <michele.calgaro@yahoo.it>2022-12-09 13:09:00 +0900
committerMichele Calgaro <michele.calgaro@yahoo.it>2022-12-10 11:58:04 +0900
commitcc22d7d083fa62523071a74683b227d838f6642f (patch)
tree5ad24d19df46d8bd0ea5acabfc3b83d5ddb8ef29 /kmymoney2/plugins/Makefile.am
parent19068f2c66533416fd57d236675e8882f5835165 (diff)
downloadkmymoney-cc22d7d083fa62523071a74683b227d838f6642f.tar.gz
kmymoney-cc22d7d083fa62523071a74683b227d838f6642f.zip
Drop automake build support.
Signed-off-by: Michele Calgaro <michele.calgaro@yahoo.it>
Diffstat (limited to 'kmymoney2/plugins/Makefile.am')
-rw-r--r--kmymoney2/plugins/Makefile.am24
1 files changed, 0 insertions, 24 deletions
diff --git a/kmymoney2/plugins/Makefile.am b/kmymoney2/plugins/Makefile.am
deleted file mode 100644
index 9b67654..0000000
--- a/kmymoney2/plugins/Makefile.am
+++ /dev/null
@@ -1,24 +0,0 @@
-KDE_OPTIONS = noautodist
-
-METASOURCES = AUTO
-INCLUDES = $(all_includes) -I$(top_srcdir) -I.
-
-# since some of the subdirs are conditional, we need to define DIST_SUBDIRS
-SUBDIRS = interfaces @OFX_IMPORTERPLUGIN@
-DIST_SUBDIRS = interfaces ofximport
-
-# The library containing the plugin base class
-lib_LTLIBRARIES = libkmm_plugin.la
-libkmm_plugin_la_SOURCES = kmymoneyplugin.cpp pluginloader.cpp viewinterface.cpp statementinterface.cpp importinterface.cpp
-libkmm_plugin_la_LDFLAGS = $(all_libraries) -version-info 0:0:0
-
-#definition of the service type
-kde_servicetypes_DATA = kmymoneyplugin.desktop kmymoneyimporterplugin.desktop
-
-# make sure this lib is build before any subdirectory
-BUILT_SOURCES = libkmm_plugin.la
-
-pluginsincludedir = $(includedir)/kmymoney
-pluginsinclude_HEADERS = kmymoneyplugin.h pluginloader.h viewinterface.h statementinterface.h importinterface.h
-
-EXTRA_DIST = kmymoneyplugin.desktop kmymoneyimporterplugin.desktop