summaryrefslogtreecommitdiffstats
path: root/kmymoney2/plugins/ofximport/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2022-03-16 23:34:43 +0100
committerSlávek Banko <slavek.banko@axis.cz>2022-03-20 18:49:09 +0100
commitfebacdee5bf580932e1937f656b475762b48acd6 (patch)
tree56cf1a5ea34db847036dd71f58e1f9d7b6f128ce /kmymoney2/plugins/ofximport/CMakeLists.txt
parent9757aeb46efff389c2b118cb373206d0720235cd (diff)
downloadkmymoney-febacdee5bf580932e1937f656b475762b48acd6.tar.gz
kmymoney-febacdee5bf580932e1937f656b475762b48acd6.zip
Conversion to the cmake building system.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit a6454b1658d325d6ff2d6ba6c349b772148798e0)
Diffstat (limited to 'kmymoney2/plugins/ofximport/CMakeLists.txt')
-rw-r--r--kmymoney2/plugins/ofximport/CMakeLists.txt52
1 files changed, 52 insertions, 0 deletions
diff --git a/kmymoney2/plugins/ofximport/CMakeLists.txt b/kmymoney2/plugins/ofximport/CMakeLists.txt
new file mode 100644
index 0000000..906b919
--- /dev/null
+++ b/kmymoney2/plugins/ofximport/CMakeLists.txt
@@ -0,0 +1,52 @@
+
+add_subdirectory( dialogs )
+
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_BINARY_DIR}/include
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}/dialogs
+ ${CMAKE_CURRENT_SOURCE_DIR}/dialogs
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### kmm_ofximport (kpart)
+
+tde_add_kpart( kmm_ofximport AUTOMOC
+ SOURCES
+ ofximporterplugin.cpp
+ ofxpartner.cpp
+
+ LINK
+ ofximport-dialogs-static
+ kmm_plugin-shared kmm_mymoney-shared
+ tdecore-shared tdeui-shared tdeio-shared tdehtml-shared
+ ${LIBOFX_LIBRARIES}
+
+ DEPENDENCIES
+ kmm-includes
+
+ DESTINATION ${PLUGIN_INSTALL_DIR}
+)
+
+
+##### other data
+
+install(
+ FILES kmm_ofximport.rc
+ DESTINATION ${DATA_INSTALL_DIR}/kmm_ofximport
+)
+
+tde_create_translated_desktop(
+ SOURCE kmm_ofximport.desktop
+ DESTINATION ${SERVICES_INSTALL_DIR}
+)