summaryrefslogtreecommitdiffstats
path: root/kmymoney2/plugins/ofximport/dialogs/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2022-03-16 23:34:43 +0100
committerSlávek Banko <slavek.banko@axis.cz>2022-03-20 18:49:09 +0100
commitfebacdee5bf580932e1937f656b475762b48acd6 (patch)
tree56cf1a5ea34db847036dd71f58e1f9d7b6f128ce /kmymoney2/plugins/ofximport/dialogs/CMakeLists.txt
parent9757aeb46efff389c2b118cb373206d0720235cd (diff)
downloadkmymoney-febacdee5bf580932e1937f656b475762b48acd6.tar.gz
kmymoney-febacdee5bf580932e1937f656b475762b48acd6.zip
Conversion to the cmake building system.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit a6454b1658d325d6ff2d6ba6c349b772148798e0)
Diffstat (limited to 'kmymoney2/plugins/ofximport/dialogs/CMakeLists.txt')
-rw-r--r--kmymoney2/plugins/ofximport/dialogs/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/kmymoney2/plugins/ofximport/dialogs/CMakeLists.txt b/kmymoney2/plugins/ofximport/dialogs/CMakeLists.txt
new file mode 100644
index 0000000..5fede97
--- /dev/null
+++ b/kmymoney2/plugins/ofximport/dialogs/CMakeLists.txt
@@ -0,0 +1,31 @@
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_BINARY_DIR}/include
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### ofximport-dialogs (static)
+
+tde_add_library( ofximport-dialogs STATIC_PIC AUTOMOC
+ SOURCES
+ konlinebankingsetupdecl.ui
+ konlinebankingstatusdecl.ui
+ konlinebankingsetupwizard.cpp
+ konlinebankingstatus.cpp
+ kofxdirectconnectdlgdecl.ui
+ kofxdirectconnectdlg.cpp
+ mymoneyofxconnector.cpp
+
+ DEPENDENCIES
+ kmm-includes
+)