summaryrefslogtreecommitdiffstats
path: root/kmymoney2/reports/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2022-03-16 23:34:43 +0100
committerSlávek Banko <slavek.banko@axis.cz>2022-03-18 12:45:23 +0100
commita6454b1658d325d6ff2d6ba6c349b772148798e0 (patch)
tree7301520567c1e8c5396af155b38d9ceb6b71334b /kmymoney2/reports/CMakeLists.txt
parentd855f704e838b0bcf33907ff38165fd1f745356b (diff)
downloadkmymoney-a6454b1658d325d6ff2d6ba6c349b772148798e0.tar.gz
kmymoney-a6454b1658d325d6ff2d6ba6c349b772148798e0.zip
Conversion to the cmake building system.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz>
Diffstat (limited to 'kmymoney2/reports/CMakeLists.txt')
-rw-r--r--kmymoney2/reports/CMakeLists.txt55
1 files changed, 55 insertions, 0 deletions
diff --git a/kmymoney2/reports/CMakeLists.txt b/kmymoney2/reports/CMakeLists.txt
new file mode 100644
index 0000000..70ab830
--- /dev/null
+++ b/kmymoney2/reports/CMakeLists.txt
@@ -0,0 +1,55 @@
+
+include_directories(
+ ${CMAKE_BINARY_DIR}
+ ${CMAKE_SOURCE_DIR}
+ ${CMAKE_BINARY_DIR}/include
+ ${CMAKE_SOURCE_DIR}/libkdchart
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${TDE_INCLUDE_DIR}
+ ${TQT_INCLUDE_DIRS}
+)
+
+link_directories(
+ ${TQT_LIBRARY_DIRS}
+)
+
+
+##### reports (static)
+
+tde_add_library( reports STATIC_PIC AUTOMOC
+ SOURCES
+ pivotgrid.cpp
+ pivottable.cpp
+ listtable.cpp
+ querytable.cpp
+ objectinfotable.cpp
+ reportaccount.cpp
+ kreportchartview.cpp
+
+ LINK
+ kmymoneysettings-static
+
+ DEPENDENCIES
+ kmm-includes
+)
+
+
+##### reportstest (static)
+
+tde_add_library( reportstest STATIC_PIC AUTOMOC
+ SOURCES
+ reportstestcommon.cpp
+ pivottabletest.cpp
+ pivotgridtest.cpp
+ querytabletest.cpp
+
+ LINK
+ reports-static
+ kmm_kdchart-shared
+
+ DEPENDENCIES
+ kmm-includes
+
+ EXCLUDE_FROM_ALL
+)