summaryrefslogtreecommitdiffstats
path: root/libkdchart/Makefile.am
diff options
context:
space:
mode:
authortpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-07-04 22:38:03 +0000
committertpearson <tpearson@283d02a7-25f6-0310-bc7c-ecb5cbfe19da>2011-07-04 22:38:03 +0000
commitdadc34655c3ab961b0b0b94a10eaaba710f0b5e8 (patch)
tree99e72842fe687baea16376a147619b6048d7e441 /libkdchart/Makefile.am
downloadkmymoney-dadc34655c3ab961b0b0b94a10eaaba710f0b5e8.tar.gz
kmymoney-dadc34655c3ab961b0b0b94a10eaaba710f0b5e8.zip
Added kmymoney
git-svn-id: svn://anonsvn.kde.org/home/kde/branches/trinity/applications/kmymoney@1239792 283d02a7-25f6-0310-bc7c-ecb5cbfe19da
Diffstat (limited to 'libkdchart/Makefile.am')
-rw-r--r--libkdchart/Makefile.am95
1 files changed, 95 insertions, 0 deletions
diff --git a/libkdchart/Makefile.am b/libkdchart/Makefile.am
new file mode 100644
index 0000000..0a1048e
--- /dev/null
+++ b/libkdchart/Makefile.am
@@ -0,0 +1,95 @@
+lib_LTLIBRARIES = libkmm_kdchart.la
+
+libkmm_kdchart_la_SOURCES = KDChart.cpp \
+ KDChartAreaPainter.cpp \
+ KDChartAxesPainter.cpp \
+ KDChartAxisParams.cpp \
+ KDChartBarPainter.cpp \
+ KDChartBaseSeries.cpp \
+ KDChartBWPainter.cpp \
+ KDChartCustomBox.cpp \
+ KDChartDataIntern.cpp \
+ KDChartHiLoPainter.cpp \
+ KDChartLinesPainter.cpp \
+ KDChartPainter.cpp \
+ KDChartParams.cpp \
+ KDChartParams_frame.cpp\
+ KDChartParams_io.cpp \
+ KDChartPiePainter.cpp \
+ KDChartPlaneSeries.cpp \
+ KDChartPolarPainter.cpp \
+ KDChartPropertySet.cpp \
+ KDChartRingPainter.cpp \
+ KDChartSeriesCollection.cpp \
+ KDChartTableBase.cpp \
+ KDChartTextPiece.cpp \
+ KDChartVectorSeries.cpp \
+ KDChartVectorTable.cpp \
+ KDChartWidget.cpp \
+ KDDrawText.cpp \
+ KDFrame.cpp \
+ KDFrameProfileSection.cpp \
+ KDXMLTools.cpp \
+ KDChartEnums.cpp \
+ KDChartAxisParamsWrapper.cpp \
+ KDChartCustomBoxWrapper.cpp \
+ KDChartParamsWrapper.cpp \
+ KDChartTableDataWrapper.cpp
+ #KDChartObjectFactory.cpp
+ #KDChartWrapperFactory.cpp
+
+libkmm_kdchart_la_LDFLAGS = $(all_libraries) -no-undefined
+libkmm_kdchart_la_LIBADD = $(LIB_QT) $(LIB_KDECORE)
+
+noinst_HEADERS = KDChart.h \
+ KDChartAreaPainter.h \
+ KDChartAxesPainter.h \
+ KDChartBarPainter.h \
+ KDChartBaseSeries.h \
+ KDChartBWPainter.h \
+ KDChartDataIntern.h \
+ KDChartDataRegion.h \
+ KDChartHiLoPainter.h \
+ KDChartLinesPainter.h \
+ KDChartNotEnoughSpaceException.h \
+ KDChartUnknownTypeException.h \
+ KDChartPainter.h \
+ KDChartPiePainter.h \
+ KDChartPlaneSeries.h \
+ KDChartPolarPainter.h \
+ KDChartRingPainter.h \
+ KDChartSeriesCollection.h \
+ KDChartTextPiece.h \
+ KDChartUnknownTypeException.h \
+ KDChartVectorSeries.h \
+ KDDrawText.h \
+ KDXMLTools.h \
+ KDChartTableBase.h \
+ KDChartListTable.h \
+ KDChartVectorTable.h \
+ KDChartTable.h \
+ KDChartParams.h \
+ KDFrameProfileSection.h \
+ KDChartPropertySet.h \
+ KDChartDataIntern.h \
+ KDChartDataRegion.h \
+ KDFrame.h \
+ KDChartGlobal.h \
+ KDChartWidget.h \
+ KDChartCustomBox.h \
+ KDChartEnums.h \
+ KDChartTextPiece.h \
+ KDChartAxisParams.h \
+ kdchart_export.h \
+ KDChartCustomBoxWrapper.h \
+ KDChartWrapperFactory.h \
+ KDChartAxisParamsWrapper.h \
+ KDChartParamsWrapper.h \
+ KDChartTableDataWrapper.h \
+ KDChartObjectFactory.h
+
+METASOURCES = AUTO
+
+# INCLUDES = $(KOFFICECORE_INCLUDES) -I$(srcdir)/.. -I$(srcdir) $(all_includes)
+INCLUDES = -I$(srcdir) $(all_includes)
+