summaryrefslogtreecommitdiffstats
path: root/developer-doc/phb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'developer-doc/phb/Makefile.am')
-rw-r--r--developer-doc/phb/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/developer-doc/phb/Makefile.am b/developer-doc/phb/Makefile.am
index 9e38295..f3024e5 100644
--- a/developer-doc/phb/Makefile.am
+++ b/developer-doc/phb/Makefile.am
@@ -19,9 +19,9 @@ STYLESHEET = tde-nochunk.xsl
phb.html: $(DOCBOOK_FILES)
@if test -e $(MEINPROC); then \
- echo $(MEINPROC) --stylesheet $(kde_libs_prefix)/share/apps/ksgmltools2/customization/$(STYLESHEET) $(srcdir)/phb.docbook -o phb.html; \
- echo sed -i "s/ISO-8859-1/UTF-8/g" phb.html; \
- $(MEINPROC) --stylesheet $(kde_libs_prefix)/share/apps/ksgmltools2/customization/$(STYLESHEET) $(srcdir)/phb.docbook --stdout | sed "s/ISO-8859-1/UTF-8/g" > phb.html; \
+ $(MEINPROC) --stylesheet $(kde_libs_prefix)/share/apps/ksgmltools2/customization/$(STYLESHEET) $(srcdir)/phb.docbook --stdout | \
+ iconv -f ISO-8859-1 -t UTF-8 | \
+ sed "s/ISO-8859-1/UTF-8/g" > phb.html; \
fi
preview: phb.html
@@ -106,10 +106,8 @@ if GENERATE_PDF
kmymoney-phb.pdf: $(DOCBOOK_FILES)
$(MAKE) get-files
$(MEINPROC) --stylesheet `dirname $(KDE_XSL_STYLESHEET)`/tde-nochunk.xsl $(srcdir)/phb.docbook -o index.html
- recode utf8..latin1 index.html || :
html2ps -o kmymoney-phb.ps -n index.html
ps2pdf kmymoney-phb.ps kmymoney-phb.pdf
rm index.html kmymoney-phb.ps
$(MAKE) clear-files
endif
-