summaryrefslogtreecommitdiffstats
path: root/kmymoney2/mymoney/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kmymoney2/mymoney/Makefile.am')
-rw-r--r--kmymoney2/mymoney/Makefile.am47
1 files changed, 0 insertions, 47 deletions
diff --git a/kmymoney2/mymoney/Makefile.am b/kmymoney2/mymoney/Makefile.am
deleted file mode 100644
index 776502a..0000000
--- a/kmymoney2/mymoney/Makefile.am
+++ /dev/null
@@ -1,47 +0,0 @@
-KDE_OPTIONS = noautodist
-
-#
-# The LIBVERSION setting controls the libtool versioning system for shared
-# libraries. It is constructed out of the triplet CURRENT:REVISION:AGE.
-#
-# Here are the rules on howto update the version info:
-#
-# 1. Update the version information only immediately before a public
-# release of your software. More frequent updates are unnecessary,
-# and only guarantee that the current interface number gets larger
-# faster.
-#
-# 2. If the library source code has changed at all since the last
-# update, then increment REVISION (`C:R:A' becomes `C:r+1:A').
-#
-# 3. If any interfaces have been added, removed, or changed since the
-# last update, increment CURRENT, and set REVISION to 0.
-#
-# 4. If any interfaces have been added since the last public release,
-# then increment AGE.
-#
-# 5. If any interfaces have been removed since the last public release,
-# then set AGE to 0.
-#
-# The above information is copied from 'info libtool'.
-
-LIBVERSION=5:0:0
-
-INCLUDES = $(all_includes) -I$(top_srcdir) -I.
-lib_LTLIBRARIES = libkmm_mymoney.la
-
-libkmm_mymoney_la_METASOURCES = AUTO
-
-libkmm_mymoney_la_SOURCES = mymoneymoney.cpp mymoneyfinancialcalculator.cpp mymoneytransactionfilter.cpp mymoneyobject.cpp mymoneykeyvaluecontainer.cpp mymoneyobserver.cpp mymoneysubject.cpp mymoneysplit.cpp mymoneyinstitution.cpp mymoneyexception.cpp mymoneyinvesttransaction.cpp mymoneyutils.cpp mymoneysecurity.cpp mymoneytransaction.cpp mymoneyscheduled.cpp mymoneypayee.cpp mymoneyfile.cpp mymoneycategory.cpp mymoneyaccount.cpp mymoneyreport.cpp mymoneystatement.cpp mymoneyprice.cpp mymoneybudget.cpp mymoneyobjectcontainer.cpp mymoneyforecast.cpp
-libkmm_mymoney_la_LDFLAGS = $(all_libraries) -version-info $(LIBVERSION)
-
-SUBDIRS = storage
-
-instdir=$(includedir)/kmymoney
-inst_HEADERS = mymoneyobject.h mymoneyaccount.h mymoneycategory.h mymoneyexception.h mymoneyfile.h mymoneyfinancialcalculator.h mymoneyinstitution.h mymoneyinvesttransaction.h mymoneykeyvaluecontainer.h mymoneymoney.h mymoneyobserver.h mymoneypayee.h mymoneyprice.h mymoneyreport.h mymoneyscheduled.h mymoneysecurity.h mymoneysplit.h mymoneystatement.h mymoneysubject.h mymoneytransactionfilter.h mymoneytransaction.h mymoneyutils.h mymoneybudget.h mymoneyobjectcontainer.h mymoneyforecast.h
-
-noinst_HEADERS = autotest.h mymoneyaccounttest.h mymoneyfinancialcalculatortest.h mymoneykeyvaluecontainertest.h mymoneyexceptiontest.h mymoneyfiletest.h mymoneyinstitutiontest.h mymoneymoneytest.h mymoneyobservertest.h mymoneyscheduletest.h mymoneysplittest.h mymoneysecuritytest.h mymoneytransactiontest.h mymoneypricetest.h mymoneyobjecttest.h mymoneyforecasttest.h mymoneypayeetest.h
-
-check_LIBRARIES = libmymoneytest.a
-
-libmymoneytest_a_SOURCES = mymoneytransactiontest.cpp mymoneysplittest.cpp mymoneymoneytest.cpp mymoneyfiletest.cpp mymoneyaccounttest.cpp mymoneyexceptiontest.cpp mymoneyinstitutiontest.cpp mymoneykeyvaluecontainertest.cpp mymoneyscheduletest.cpp mymoneyfinancialcalculatortest.cpp mymoneysecuritytest.cpp mymoneypricetest.cpp mymoneyobjecttest.cpp mymoneyforecasttest.cpp mymoneypayeetest.cpp