summaryrefslogtreecommitdiffstats
path: root/kmymoney2/reports/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'kmymoney2/reports/Makefile.am')
-rw-r--r--kmymoney2/reports/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/kmymoney2/reports/Makefile.am b/kmymoney2/reports/Makefile.am
new file mode 100644
index 0000000..d6d050f
--- /dev/null
+++ b/kmymoney2/reports/Makefile.am
@@ -0,0 +1,16 @@
+KDE_OPTIONS = noautodist
+
+INCLUDES = $(all_includes) -I.. -I$(top_srcdir) -I. -I$(top_srcdir)/libkdchart
+
+noinst_LIBRARIES = libreports.a
+libreports_a_METASOURCES = AUTO
+
+libreports_a_SOURCES = pivotgrid.cpp pivottable.cpp listtable.cpp querytable.cpp objectinfotable.cpp reportaccount.cpp kreportchartview.cpp
+
+noinst_HEADERS = kreportchartview.h kreportsviewtest.h pivotgrid.h pivottable.h pivottabletest.h pivotgridtest.h listtable.h querytable.h querytabletest.h objectinfotable.h reportaccount.h reportdebug.h reportstestcommon.h kreportchartview.h reporttable.h
+
+if CPPUNIT
+check_LIBRARIES = libreportstest.a
+
+libreportstest_a_SOURCES = reportstestcommon.cpp pivottabletest.cpp pivotgridtest.cpp querytabletest.cpp
+endif