summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2018-10-26 04:07:01 +0200
committerSlávek Banko <slavek.banko@axis.cz>2018-10-27 13:36:02 +0200
commit42673b0179d00e2b5a05fb48438577b923f00b8b (patch)
treec42ef21f0799c5e73ae1ccb6ed439d690ec9e59c /CMakeLists.txt
parent0e396d6b00651d811959f8d4c7ccad9ff868a1a1 (diff)
downloadknetstats-42673b0179d00e2b5a05fb48438577b923f00b8b.tar.gz
knetstats-42673b0179d00e2b5a05fb48438577b923f00b8b.zip
Fix structure of directories
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 06772a369f2beef80bb291ded30cbe125a24af56)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 00718bc..938bb69 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -68,9 +68,19 @@ set( CMAKE_MODULE_LINKER_FLAGS "-Wl,--no-undefined" )
##### directories
add_subdirectory( src )
+add_subdirectory( icons )
+tde_conditional_add_subdirectory( BUILD_DOC doc )
tde_conditional_add_subdirectory( BUILD_TRANSLATIONS translations )
##### write configure files
configure_file( config.h.cmake config.h @ONLY )
+
+
+##### other data
+
+install(
+ FILES ${PROJECT_NAME}.desktop
+ DESTINATION ${XDG_APPS_INSTALL_DIR}
+)