summaryrefslogtreecommitdiffstats
path: root/translations/messages/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2020-04-29 22:54:53 +0200
committerSlávek Banko <slavek.banko@axis.cz>2020-04-29 22:56:09 +0200
commit0f5a9df401837ac8dafd2a701884e1b2d1f4a777 (patch)
treef1539364e51af54e4093eed7e47296d1a63ced4a /translations/messages/CMakeLists.txt
parent4e1d0a800b46cf15e39f270f2be64f9974b24bf6 (diff)
downloadknetstats-0f5a9df401837ac8dafd2a701884e1b2d1f4a777.tar.gz
knetstats-0f5a9df401837ac8dafd2a701884e1b2d1f4a777.zip
Move translations to a new directory layout.
Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 32deb698992f388f6791251fceef61cf142b326e)
Diffstat (limited to 'translations/messages/CMakeLists.txt')
-rw-r--r--translations/messages/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/translations/messages/CMakeLists.txt b/translations/messages/CMakeLists.txt
new file mode 100644
index 0000000..75c89f8
--- /dev/null
+++ b/translations/messages/CMakeLists.txt
@@ -0,0 +1,14 @@
+file( GLOB_RECURSE po_files RELATIVE ${CMAKE_CURRENT_SOURCE_DIR} *.po )
+string( REGEX REPLACE "[ \r\n\t]+" ";" _linguas "$ENV{LINGUAS}" )
+
+foreach( _po ${po_files} )
+ get_filename_component( _lang ${_po} NAME_WE )
+ if( "${_linguas}" MATCHES "^;*$" OR ";${_linguas};" MATCHES ";${_lang};" )
+ if( "${_po}" MATCHES "^([^/]*)/.*" )
+ string( REGEX REPLACE "^([^/]*)/.*" "\\1" _component "${_po}" )
+ else( )
+ set( _component "${PROJECT_NAME}" )
+ endif( )
+ tde_create_translation( FILES ${_po} LANG ${_lang} OUTPUT_NAME ${_component} )
+ endif( )
+endforeach( )