summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSlávek Banko <slavek.banko@axis.cz>2019-01-05 14:59:47 +0100
committerSlávek Banko <slavek.banko@axis.cz>2019-01-05 15:00:20 +0100
commitaaa6171d35da76573357868b0607dfff2f71db46 (patch)
tree11834c2e0f445630887354cbee68b5318fa8170d /CMakeLists.txt
parent4b34b71923672a32f25ef5ef573e23645a6da67f (diff)
downloadknights-aaa6171d35da76573357868b0607dfff2f71db46.tar.gz
knights-aaa6171d35da76573357868b0607dfff2f71db46.zip
Added controlled conversions to char* instead of automatic ascii conversions.
The definition of -UTQT_NO_ASCII_CAST is no longer needed. Signed-off-by: Slávek Banko <slavek.banko@axis.cz> (cherry picked from commit 9e120e0d4bd46ebc619390f23ef874542f6548cf)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c232807..0327668 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,7 +58,7 @@ include( ConfigureChecks.cmake )
###### global compiler settings
-add_definitions( -DHAVE_CONFIG_H -UQT_NO_ASCII_CAST )
+add_definitions( -DHAVE_CONFIG_H )
set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${TQT_CXX_FLAGS}" )
set( CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -Wl,--no-undefined" )