summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorgregory guy <g-gregory@gmx.fr>2019-01-29 13:07:14 +0100
committergregory guy <g-gregory@gmx.fr>2019-01-29 13:07:14 +0100
commit8181cadea726f243b3738bff0151012acd58f42d (patch)
treecc41af7d76d94ec9d466568aaa535494f17533d2 /CMakeLists.txt
parentf5f1f0ef7e0e540baa36b925088eaa23f28c5d4a (diff)
downloadknights-8181cadea726f243b3738bff0151012acd58f42d.tar.gz
knights-8181cadea726f243b3738bff0151012acd58f42d.zip
fulfill bug request 2663.
Thanks to Kristopher 2016-06-13 for the request. These extra themes come from https://sourceforge.net/projects/knights/files/knights-themepack They are released under the GNU GPL Version 2 Signed-off-by: gregory guy <g-gregory@gmx.fr>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0327668..f0f4eac 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -49,6 +49,7 @@ option( WITH_GCC_VISIBILITY "Enable fvisibility and fvisibility-inlines-hidden"
option( BUILD_ALL "Build all" ON )
option( BUILD_DOC "Build documentation" ${BUILD_ALL} )
option( BUILD_TRANSLATIONS "Build translations" ${BUILD_ALL} )
+option( BUILD_EXTRA_THEME "Build extra-theme" ${BUILD_ALL} )
##### configure checks
@@ -71,6 +72,7 @@ add_subdirectory( ${PROJECT_NAME} )
add_subdirectory( media )
tde_conditional_add_subdirectory( BUILD_DOC doc )
tde_conditional_add_subdirectory( BUILD_TRANSLATIONS po )
+tde_conditional_add_subdirectory( BUILD_EXTRA_THEME extra-theme )
##### write configure files